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PWagqui tutorial:
a PWscf's Graphical User Interface

PWgui == PWscf GUI
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Copy me ...

* This tutorial can be downloaded from:

http://[ ESPRESSO TUTORI AL- SI TE] /tutori al _pwgui . pdf

* PWgqui (linux binary package) can be copied from:

http://[ ESPRESSO TUTORI AL- SI TE] / pwgui - | i nux- x86. zi p
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Basic scheme @ PWscf

prepare by PWgui

v

pw. X < stdin > stdout

) t

analyze by XCrySDen
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Basic scheme @ PWscf [extended]

* make SCF calculation:
X D
PWaui analyze by XCrySDen

pw. X < stdin > stdoﬁt/
Sout put : prefix. *

* calculate property) .
Y PWgui

pp. X < stdin > stdout
Sout put :  filplot
\J
* transform the data:}
PWgui

r'e .
pp. X < stdin > stdout
Sout put :  fileout < analyze by XCrySDen
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PWgui == PWscf GUI

v IS free software (GNU General Public License)

v WEB page.:
http://ww. pwscf.org/, there is link to:
http://ww+k3.1]s.si/kokalj/pwgui/



http://www.pwscf.org/
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PWgui and GUIB

CONSIDER: inputs for numerical simulation software
are simple from computer perspective

IDEA: construct a two-purpose meta-language:
* define the input syntax }

* provide automatic GUI construction

GUIB: simple Graphical User Interface Builder
http://wwk3.1]s.si/kokalj/gulb/
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What is GUIB

GUIB is an engine for building GUIs for numerical simulation

software:

v define the input syntax of your input
v automatic GUI construction

GUIB is free software (GPL)
http://www-k3.ijs.si/kokalj/quib

GUIB engine is used for

PWgqui — a GUI for the
PWscf set of programs

| Fle Edit \iew Web Go Bookmarks Tabs Help
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Menu What is GUIB ?
Home
About Project description B
Description Guib is a utility library that facilitates the creation of graphical
user interfaces (GUI) aimed at creating and manipulating input
Documen tation files for numerical simulation programs.
Download The name Guib stands for Graphical User Interface Builder.
Install Guib is also a west african antelope (Tragelaphus scriptus).
Developer Inf
qui Read more ...
EWaui Maintainers:
Anton Kokalj
News Developers:
R 1 Ao Wnlald =3
| ol




DEMOCRITOS

DEmocritos MOdeling Center for
Research In aTOmis TI?" Simulation INF

How GUIB works

(1) Consider the following input:

K PO NTS automatic
8 8 8
111

(3) Corresponding GUI [automatically
constructed on the basis of definition (2)]

& (an example GUI (No.O) El=1L. ]

File

(2) Define the input syntax:

—Line: K-point input

- Gamma point anly

K-Pointinput 4 Automatic generation

—Line: K-point mesh

Inm: [e ﬁ |Ink2: C _ |Inka: E Al

—Line: K-point mesh shift

~|

Is1: |1 —_ ||52: |1 = |Isa |1 Al

module examplelifaute -title "Bn example GUI" -script {

# lst-line of input
line ktype -name "EK-point input" {
kevword kpoints E_POINTS

war kpoint tvpe |

-label "E-Point input"

-textvalue { "BDutomatic generation" "Gamma point only" )
—wvalus { automatic gamma |}

—widget radichox

# 2Znd-line of input
line kmesh -name "E-point mesh" |

packwidgets left

war nkl -label "nkl:" -widget entry
war nkZ -lakel "nkZ:" -widget entry
war nkd -lakel "nk3:" -widget entry

# 3rd-line of input
line kshift -name "E-point mesh shift"

packwidgets left

wvar sl —label "sl: -widget entry

war 52 -label "s2:" -—widget entry

war 53 -label "s53:" -widget entry

-validate posint
-validate posint

-validate posint

—validate posint -default 1
-wvalidate posint -default 1

-wvalidate posint -default 1

—default 1
—default 1
—default 1
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input

e example:

GUI based on GUIB

 a GUI based on GUIB closely follows the structure of the

W (simalation

Setup (No.0)

File

=8%

water molecule
&parameters
job_type
functional = B3LYP
basis_set = 6-311G
&end
Input_Geometry

H 0.000 0.773
0 0.000 0.000
H 0.000 -0.773
End

= optimization

-0.5bb
0.139
-0.5bb

—Line: Title

Jab titke:

—MNamelist: Parameters

Job type: Structural o ptimzation - |
DFT Functional: BaLYP - |

Gaussian basis set: 631G -
‘ Enter atomic coorditanes ‘
| Atomic symbol | %-Coondinate | Y-Coordinate | Z-Coordinate
1 H 0.000 0.773 0555
20 10.000 0.000 0.139
aH 0.000 0773 |-0.559

the function of such GUI is to manage input files
(creation + editing)
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PWaqui installation

* PWaqui comes in two flavors:

- binary standalone package (for Linux / MAC OSX)
— source package

* Installation of binary (standalone) package:

— download PWgui from ht t p: / / www. pwscf . org/ or
http://ww k3.1]s.si/kokalj/pwgui/

— unzip (or untar) the package

- execute: . / pwgul

* [nstallation of source package:

— define environmental variables

« export PWGEU =/ pat h/t o/ PWjui - 3. 1 (syntax for bash shell)
e add $PWAUl to path: PATH=$PATH: $PWGU

e execute: ./ pwgui



http://www.pwscf.org/
http://www-k3.ijs.si/kokalj/pwgui/
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PWgui: what it provides?

* manages (create and edit) inputs for the following modules:

PW. X
ph. X

Pp. X

proj w c. x

| d1. x (atom c)
d3. x

* contains help:

* User's manual

o | NPUT _* files

* description of individual variables (Hel p buttons)
e visualization of structure: PWjui uses XCRYSDEN
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Let's start using PWgui

W O pi AP S CF s G|

File Edit View Run

-1 L5

[ pwgui

launch: .

create new Input
open existing input
save current input
save current input as

a/GUI for PWscft

PWscf copyright: (¢)*200 1=-2004 by PWsctf grou

(Stefano Baroni,. Stefano de Gironcoli, Andrea Dal Corso, Paole Giannozzi)
PWgui copyright: () 2003--2004 by Anton Kokalj

Plane- Wave Self~Cnnsistent Field
B . :

iE;EEss_.

close current page
exit

R A PARTICULAR PURPOSE.

without even

PWscf and .P‘ngm distributed in the hope that they.@:ill be useful,
but WITHOUT TY:
warranty of MERCIIAN’E@BILI’I‘Y or FITNESS FOR A ;
See the GNU General Pu%c-ucense for more detai]s%_
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Create a new pw.x input file

 select menu: File->New I nput ...->New PW X | nput

 PWgui opens a new page, which contains several pages:

+ one page per each namelist
+ one page for CELL_PARAVETERS/ ATOM C_SPECI ES/ ATOM C_PCsI TI ONS cards
+ one page for k_ra NTs card

+ one page for cLI MBI NG_| MAGES/ OCCUPATI ONS cards




" DEMOCR|TOS
DEmocritos MOdeling Center f /
Resnc;::lﬁ.[h :' oTOr%ilsrﬂ?: Simnu%rt C?I; INFBI

Create a new pw.x input file

* the input constructed by PWgqui is syntactically correct, BUT the
STRINGS MUST BE QUOTED. Example:

pseudo dir = O/home/ tone/pw/ pseudo/o

Temporary directory (outdir): cratn:hftnnefpwfexamplm Directory ... |
Directory containing pseudopotential files (pseudo_dir:) IE Dmex‘tnnefpwfpseud Directory ... |

Prefix for IO filenames (prefix): ‘geample o

VvV
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Display help for pw.x

* description of variables:
use Hel p buttons on the right

* description of whole pw.x input:
select menu: Hel p- >PW X | nput Synt ax

e PWscf User's manual:
select menu: Hel p- >PWSCF User's gui de
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Event driven mechanism

* on Control page select:
Type of calculation =Sel f-Consistent-field

— goto lons page: all items are disabled

* on Control page select:
Type of calculation =lonic-relaxation

— goto Jons page: some items are enabled now.

* select a given type of ionic dynamics (first item): more items get
enabled ...
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Viewing input in text-mode

* on Control page select:
Type of calculation =Sel f-Consistent-field

* now try the following menu items:

e View>lnput file

( text layout of appropriate pw.x's input isdisplayed )

* now try input-layouts for other types of calculations ...
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Editor vs. GUl mode

 from menu: Fil e->Cpen I nput ...->Cpen PW X | nput

* select file: vour EsPresso pDIR/ exanpl es/ exanpl e03/ resul ts/al 001.rx.in

(NOTE: the input files are there after example03 has been run)

* now try the following menu items:

e Edit->Input with editor
e Edit->Input's copy with editor
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PWgui & XCrySDen: visualization

* try menu: Vi ew >Structure with XCRYSDEN

( xcrysden will display structure; Note: XCrySDen should be
installed first. See the other tutorial )

* xcrysden in PWgui's page:
- select the PWgui's menu: Fi | e- >Set ti ngs

* on PWgui settings page select:
- | aunch XCRYSDEN=I1 n not ebook page

— retry the menu: Vi ew>Structure with XCRYSDEN
(xcrysden will appear inside PWgui as a new notebook page)
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Input error checking

e select menu: Edit->Input with editor

* make an error on purpose, for example, add an undefined variable:

&CONTRCL
nmy_var = 'ny_val ue',
calculation = 'rel ax',

* save the file and exit from editor: PWgui will complain !!

* Message: when PWgui complains about input, then the input
probably contains syntax errors !!!
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More info about installation

* PWaqui is written in [incr Tcl], which is a scripting language:
- ADVANTAGE: no compilation
- DISADVATAGE: source-package requires [incr Tcl] and related software

* How to install [incr Tcl] and related software:

- Compile sources:

* For Tcl/Tk see: http://www.scriptics.com/
* For ITcl/ltk/lwidgets see: http://incrtcl.sourceforge.net/
— Tcl binaries (for a few platforms only)

* ActiveTcl (contains everything):
http://www.activestate.com/Products/Download/Download.plex?id=ActiveTcl



http://www.scriptics.com/
http://incrtcl.sourceforge.net/
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PWgui: about modules

* modules are defined in $PWBUI / nodul es directory

* each module is in its own directory

« example: pw. X module:

— located in pw/ subdirectory

- files:

e pw. t cl — definition of input syntax and GUI
 pw event .t cl — event driven mechanism
 pw hel p. t cl — help for variables

e commands. t cl — various functions for GUI
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1% pw.x example by PWgui

* create a simple pw.x’ input for an SCF calculation with the
PWgui

e structure: SI bul k
- lattice parameter: 10. 2 Bohr
- Braivas lattice: f cc-cubi c
— cutoff energy: 18.0 ryd
- pseudopotential: Si . vbc. UPF

— atomic positions (crystal units):
Si 0.00 0.00 0.00
Si 0.25 0.25 0.25

- k-point mesh: 4x4x4
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Define PWscf executables

* select the PWgui's menu: Fi | e- >Set ti ngs

- a new window will appear, select page: PWscf setti ngs

Example: | proper/ pat h/ t o/ pw. X

0]
@]

PWsc! setings | PWquisetings | DEBUG settings
\

Prefix & postfix (i.e. Prefix = mpirun -np 2 && Postfix = -npool 2)
Prefiz: I
Postfiz: I

\ Specify executables (i.e. /usr/local/bin/pw.x)
Executable "pwr.x": \ shomedone/prog/PWsCR/CY S/KokalfO-sesamesbin s File ... |
deflne PWSCf Executable "ph.x": ‘shomefane/prog/PWsCR/CY S/KokalfO-sesamesbinph.x File ... |
executables here: Executable "pp.x": shomedone/prog/PWSCR/CY S/Kokal/O-sesamesbindppx File ... |
|
|

these are used —
for parallel execution

Set the proper path Executable "projwfc.z": shomedone/prog/PWSCRACY SAKokal/O-sesamesbinprojwfc.< File ...

Executable "d3.x": shomedone/prog/PWSCR/CY S/Kokal/O-sesamesbinddsx File ...

Close | Save | Apply | | Apply & Close |
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Page: Control

File Edit View Run

DBEANOV —

PW.X Input (No.0) \

m System | Electrons | lons |Variab|e Cell | Phonen | Lattice & Atomic data | K-point data | Other Cards —

—MNamelist: CONTROL

Optional variables
Joh Title (title): I'Si—bulk' Help |

Type of calculation {calculation): Self-Consistent-Field <scf> Help
Band structure calculation <nscf:

+

Phonon calculation =phonon=

lonic relaxation <relax>

lonic relaxation with Variable-Cell <vc-relax=
Molecular dynamics <md=

Molecular dynamics with Varable-Cell <vc-md=
Hudged Elastic Band <neh-

String Method Dynamics <smd>

LKL

Meta-dynamics <metadyn:

Maximum CPU time [in seconds] (max_seconds):

l

Help

Restart mode (restart_mode): from scratch <from_scratch> = Help —

Make a single restart file (wf_collect): - Yes Help

+ HO

--- Directories/hles/Stdout ---
Temporary directory (outdir): I'fscratchf}{}{}{}{fSi—bulkf' Directory ... | Help

Temp. directory for files generated by each CPU (wfcdir): I Directory ... | Help
Directory containing pseudopotential files (pseudo_dir:) I Directory ... | Help

Prefix for 170 filenames (prefix): I Help
Disk InputfOutput {disk_io): il Help
Verbosity of output (verbosity): — Help
Interval {in 3CF iterations) for printing band energies (iprint): = Help | /
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File Edit View Run

BISZ=2-" K> X0,

PW.X Input (No.0) \

Control W Electrons | lons |Variab|e Cell | Phonen | Lattice & Atomic data | K-point data | Other Cards —

—Mamelist: SYSTEM

GELIIELREGELEN Optional variables

Braivas lattice index (ibrav): ICubic F (fcc) ﬂ

Help

—Lattice specification:
How to specify lattice: 4 by celldm() Help
-~ by A,B,C,co08AB,c0SAC,c0SBC

— Crystallographic constants (celldm)
celldm(1}: |1 0z Help
celldm{z): I Help
celldm(3): I Help
celldm{4): I Help
celldm(5): I Help
celldm(6): I Help

A I Help B: I Help IC: I Help

cosAB: I Help IcusAC: I Help IcusBC: I Help

Humber of atoms in the unit cell (nat): Z = Help
. . |
Humber of types of atoms in the unit cell {ntyp): 1 = Help
Kinetic energy cutoff for WAVEFUNCTION [in Ryd] (ecutwic): |1 g.0 Help
Kinetic energy cuttof for DENSITY [in Ryd] {ecutrho): I Help

=
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PW.X Input (No.0) \

Control | System | Electrons | lons |Variab|e Cell | Phonon Lattice CENCIIERCE Y K-point data | Other Cards ||

Line: Lattice type

Lattice type: 4 cubic Help

~ hexagonal

| Enter Lattice Basis Vectors: |

| %Component | V-Component | Z-Component

i | |
3 | |
B | |

Enter atomic types: |

Help
Atomic-label Atoimic-Mass Pseudopotential-file
FSi 1.0 Sivbc UPF Pseudopotential ... |
Line: Atomic coordinate unit
Atomic coordinate length unit: ~ Cartesian in ALAT (i.e. in length units of celldm{1)) <alat= Help

-~ Cartesian in BOHR <hohr>
- Cartesian ihn ANGSTROMS <angstroms>
4 Intemal crystal coordinates <crystal»

Humber of intermediate images: ID > Help ‘

| Enter atomic coordinates: |

Load atomic coordinates from file ... | Help

| Atomic-label | %-Coordinate | V-Coordinate | Z-Coordinate | X-iforce | V-iforce | Z-iforce
lsi 0.00 0.00 [0.00 = o 5
2 |si 0.5 0.25 025 | o 5

=

e —
L |
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File Edit View Run Help

B2 2 <X o) G

PW.X Input (No.0) \

Control | System | Electrons | lons |Variab|e Cell | Phonon | Lattice & Atomic data K—point CEVEN Other Cards =

—Line: K-point input

K-Point input ~ Manual specification in Zpifa units <tpiba= Help
-+ Manual specification in CRYSTAL units <crystal>
4 Automatic generation <automatic»

~ Gamma point only <gammasz

—Line: Number of K-points

- -

Humber of K-points: 1 = Help ‘
—Line: K-point mesh + shift

Nk |4 i Help | fnkz: |4 i Help | fnks: |4 i Help

| Enter the coordinates of the K-points below: |

Load K-point coordinates from file ... | Help

| KxX-Coordinate | Kv-Coordinate | KZ-Coordinate | Weight

=
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Visualize and run

* to see the input file select menu item:
View -> Ilnput File

* to visualize the structure select menu item:
View -> Structure wth XCySDen

* to run calculation use, for example, menu item:

Run -> Run cal cul ati on 2 EURPILE) ElEE
Directory: fhomeskatarina | | |
- PWgui will ask you to save the input: €7 Abisute £ gnome £ ke
7 .adobe £ .gnomeg £7 local
SLvARNING ] .gconf 7 .gnomeZ_private ] .mcop
/Y Some variables are not set. £ .goonfd 1 .gstreamer-0.8 (] .metacity
. . . List of unset variables:
— ignore this message: | ccutrno = | p
atomic_coordinates(1,5)
atomic_coordinates(1,6) File name: |samp|e.pw.inp a3ave
atomic_coordinates(1.7)
atomic_coordinates(2,5) Files of type: PW.X Input Fle (*.pw.j= | Cancel
atomic_coordinates(2,6)

atomic_coordinates(2,7)

Dou you still want to save a
file?




